Announcement

Collapse
No announcement yet.

86 electronic ignition no spark

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    86 electronic ignition no spark

    Does anyone have experience with the mid 80s electronic ignition systems please?

    I've suddenly got no spark. Have tried another coil but no dice. I have no idea how to test the module or dizzy.

    Many thanks.


    65 289 auto convertible SOLD
    65 351 4 speed fastback
    65 289 coupe
    65 289 coupe

    #2
    Will this help, Colin? http://easyautodiagnostics.com/ford/...module-tests-1

    Comment


      #3
      Originally posted by sillysod View Post
      Thanks for that but its the earlier type with the separate box type module. I think that's the later TFI set up in that link. Might be similar enough to help though thanks. Been Google searching but can't seem to come up with much help for some reason so was hoping someone on here might have had the same issue.


      65 289 auto convertible SOLD
      65 351 4 speed fastback
      65 289 coupe
      65 289 coupe

      Comment


        #4
        SBFtech.com is your solution
        Please visit our Classic Mustang for sale site: www.classicamericancarsales.co.uk
        We stock a large selection of freshly imported Classic 1960s Mustangs. Fastbacks, Convertibles and Coupes. Cars are in stock in the Southeast of England with more shipping from the USA at all times. Other interesting American cars also stocked. CSRP disk brake setups sold

        Comment


          #5
          Originally posted by pmustang View Post
          SBFtech.com is your solution
          Sounds like a good lead, as i've got an 86' and haven't got a clue

          ---1969 Sportsroof -----------------1986 GT-------------------1995 V6

          Comment


            #6
            From everything I've read, the 1986 on 5.0 used the TFI and the '85 used the Duraspark 2. The magnetic pick up inside the distributor or the module itself are possible culprits. The system is similar to that used on the Capri 2.8i.
            Last edited by sillysod; 19-10-2015, 08:15 AM.

            Comment


              #7
              Thanks fellas. I have to confess that this issue is on my late 86 351w Econoline day van but as said it's the same system as on the 2.8 capris, escorts etc of the early/mid 80s. My van is just pre EFI I think.


              65 289 auto convertible SOLD
              65 351 4 speed fastback
              65 289 coupe
              65 289 coupe

              Comment

              Working...
              X