Announcement

Collapse
No announcement yet.

User Profile

Collapse

Profile Sidebar

Collapse
Profile Picture
Scimmich
Guest
Last Activity: 12-08-2019, 01:48 AM
Joined: 03-03-2019
Location:
  • Filter
  • Time
  • Show
  • Source
Clear All
new posts

  • The system won't hold pressure with 2 new caps so I think bottle has gone. Just ran it up to 97 obd read temp and 80 ir thermometer and it started pissing out behind the brand new fomoco cap still no pressure in pipes. Only leaks behind cap facing engine so I assume the bottle neck is deformed. I'll...
    See more | Go to post

    Leave a comment:


  • Just done a test as I noticed the coolant pipes always felt soft. I let car idle for 25 minutes or so temp was 90c thermostat opened. Pipes still feel soft no pressure. Water in bottle expanding to top past top cold fill line. But if I apply pressure with the coolant pressure tester the pipes feel...
    See more | Go to post

    Leave a comment:


  • Currently hose above t stat on right side going into bridge over manifold gets around 88 to 89c etc, idle test, top rad hose on left is 79 to 86, top of rad is very hot near plastic cover, but the lower pipe going into the t stat underneath it is around say 40c to 50c. Always feels relatively cool....
    See more | Go to post

    Leave a comment:


  • Interesting they operate quite high. Do the dgas bottle necks also fail? I will do a obd scan on temp to get the head temperatures and see if my new cap holds until threshold for fan to kick in. Unless the other cap just failed after 50 miles only. Do you think putting a new t stat in is advisable...
    See more | Go to post

    Leave a comment:


  • Yea fan works if a.c. is on only it seems engine bay open good flow with fan. I assume it's high speed only as it seems powerful. Did this once before changed cap to a stant one but I ran mainly using a.c. on warm days so the fan kept it cool as it cooled the condenser. But ran without on a 3 mile run...
    See more | Go to post

    Leave a comment:


  • Did a check of the Bec box and no melted terminals, a.c. kicks fan on but other day I boiled out my cap again with a.c. on car is fine as soon as a.c. was off and I stopped it threw up though not sure how hot it got. Looked at the plug going into resistor on fan and looks clean etc. I am going to test...
    See more | Go to post

    Leave a comment:

No activity results to display
Show More
Working...
X